Service Disruption - eCash Reconciliation Files

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe

Reference ID: INC0268937
Posted Jul 03, 2025 - 08:28 UTC

Update

Please be advised we are continuing to investigate with the highest priority the incident affecting the availability of eCash reconciliation files in the Distributor Service Center.
Yesterday's files are still not uploaded, but today's files are available.
We are working to restore the missing files and identify the cause of the issue with SAP.
Next update will be provided when more information is available.

If you have any questions, please don't hesitate to contact us at techsupport@paysafecard.com
MIM Paysafe

Reference ID: INC0268937
Posted Jul 02, 2025 - 09:55 UTC

Investigating

We are investigating issues with our Reconciliation Files and apologize for the impact this might have on your business.
Our technical teams are working on a solution and will keep you informed on progress.

If you have any questions, please don't hesitate to contact us at techsupport@paysafecard.com
MIM Paysafe

Reference ID:INC0268937
Posted Jul 01, 2025 - 10:56 UTC
This incident affected: Paysafecard (distributor) (eCash Reconciliation Files).