Rapid Transfer degradation
Incident Report for Paysafe
Resolved
The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
MIM Paysafe
Posted Jul 14, 2024 - 20:47 UTC
Investigating
We are investigating a degradation with the service mentioned below caused by our 3rd party "TrueLayer" .
we apologize for the impact this might have on your business.

Further updates will follow.

MIM Paysafe
Posted Jul 14, 2024 - 19:38 UTC
This incident affected: Rapid Transfer.