Service Disruption - TSYS

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe

Reference ID: INC0295082
Posted Jan 30, 2026 - 03:18 UTC

Identified

Please be advised that due to a technical issue some chargebacks may be processed with a day delay. The issue has been fixed and no more impact is expected. We apologize for the impact this may have on your business.

Reference ID: INC0295082
Posted Jan 29, 2026 - 19:53 UTC
This incident affected: Direct Marketing (TSYS USPP Funding).