Service Disruption - Unity Merchant Portal Degradation
Incident Report for Paysafe
Resolved
The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe
Posted Jul 26, 2024 - 16:49 UTC
Investigating
We are investigating a potential issue with the service mentioned below and apologize for the impact this might have on your business.

Further updates will follow.

MIM Paysafe
Posted Jul 26, 2024 - 11:23 UTC
This incident affected: Merchant Portals (Unity Merchant Portal).