PagoEfectivo Service Disruption

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.

We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while we were remediating the situation.
If you have any questions, please don't hesitate to contact us at techsupport@paysafecard.com
MIM Paysafe

Reference ID: INC0255767
Posted Mar 20, 2025 - 09:00 UTC

Investigating

We are investigating issues with our PagoEfectivo service and apologize for the impact this might have on your business.
Our technical teams are working on a solution and will keep you informed on progress.

If you have any questions, please don't hesitate to contact us at techsupport@paysafecard.com
MIM Paysafe

Reference ID: INC0255767
Posted Mar 20, 2025 - 08:40 UTC
This incident affected: PagoEfectivo (CIP Generation) and Paysafecard (merchant) (eCash PagoEfectivo).