Please be advised that the maintenance has been successfully completed within the scheduled time. We apologize for the impact this issue may have had on your business. Reference ID: CHG0280382
Posted May 16, 2025 - 05:53 UTC
Update
Please note that we encountered unexpected issues during the maintenance. You may experience a prolonged downtime duration. We apologize for the impact this issue may have on your business. We will provide updates shortly.
Reference ID: CHG0280382
Posted May 16, 2025 - 05:05 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 16, 2025 - 03:00 UTC
Scheduled
Please be advised that on Thursday, June 15 from 11:00 PM - June 16 02:30 AM ET (May 16 from 3:00 – 6:30 UTC), Paysafe will be undergoing maintenance in one of its datacenters.
We anticipate up to 1 hour of downtime of the PXP services and thank you for your understanding.
Reference ID: CHG0280382
Posted May 13, 2025 - 11:08 UTC
This scheduled maintenance affected: Direct Marketing (ApplicationXP Onboarding, PXP Gateway, PXP Webhost API, TSYS USPP Funding, Insight).