Venmo Service Disruption

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe

Reference ID: INC0256214
Posted Mar 26, 2025 - 17:25 UTC

Monitoring

A solution has been implemented and activity on the impacted services is being monitored.
We will keep you informed on progress.

MIM Paysafe

Reference ID: INC0256214
Posted Mar 26, 2025 - 17:04 UTC

Update

The root cause of this incident has been identified and our technical teams are working on implementing a solution.
We will keep you informed on the progress.

MIM Paysafe

Reference ID: INC0256214
Posted Mar 26, 2025 - 15:40 UTC

Identified

We have identified an issue with processing Venmo transactions and apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID: INC0256214
Posted Mar 26, 2025 - 15:32 UTC
This incident affected: iGaming APMs (iGaming - Venmo).