Multibanco Service Disruption

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner Multibanco/SIBS. was remediating the situation.
MIM Paysafe

Reference ID:INC0257333
Posted Apr 09, 2025 - 14:33 UTC

Monitoring

Our provider Multibanco/SIBS. implemented a solution and we are monitoring the impacted services.

MIM Paysafe

Reference ID:INC0257333
Posted Apr 09, 2025 - 14:03 UTC

Update

We are continuing to investigate this issue.
Reference ID: INC0257333
Posted Apr 09, 2025 - 13:45 UTC

Investigating

We are investigating а potential issue with our provider SIBS (Multibanco) and apologize for the impact this might have on your business.

Further updates will follow.

Reference ID: INC0257333


MIM Paysafe
Posted Apr 09, 2025 - 13:30 UTC
This incident affected: Third Parties (Multibanco).