Service Disruption - NetBanx Back Office

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe

Reference ID: INC0254514
Posted Mar 11, 2025 - 17:03 UTC

Monitoring

A solution has been implemented and activity on the impacted services is being monitored.
We will keep you informed on progress.

MIM Paysafe

Reference ID:INC0254514
Posted Mar 04, 2025 - 16:06 UTC

Investigating

Please be advised we are experiencing a service degradation affecting Activity Reports due to latency and intermittent timeouts across multiple merchants.
The teams are actively investigating the cause of issue. More updates will be provided according to the development of the investigation.

MIM Paysafe

Reference ID:INC0254514
Posted Mar 03, 2025 - 17:37 UTC
This incident affected: Merchant Portals (NetBanx Back Office).