Service Disruption - Interac & Webhooks Notification Delivery API

Incident Report for Paysafe

Resolved

This incident has been resolved.

We apologize for the impact this might have on your business.

MIM Paysafe

Reference ID:INC0297856
Posted Feb 21, 2026 - 09:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.

Reference ID:INC0297856
Posted Feb 21, 2026 - 08:27 UTC

Update

The issue has been identified and a fix is being implemented.

Reference ID:INC0297856
Posted Feb 21, 2026 - 08:07 UTC

Identified

The issue has been identified and a fix is being implemented.

Reference ID:INC0297856
Posted Feb 21, 2026 - 07:43 UTC

Investigating

We are investigating a potential issue with the service mentioned below and apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID:INC0297856
Posted Feb 21, 2026 - 07:23 UTC
This incident affected: Third Parties (Interac e-Transfer) and Processing and APIs (Webhooks Notification Delivery API).