EU Acquiring Merchant Payments Delay

Incident Report for Paysafe

Resolved

The incident has been resolved successfully.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe

Reference ID: INC0268413
Posted Jun 27, 2025 - 12:17 UTC

Identified

Please be advised we experienced a technical issue that has affected batch processing and subsequent merchant payments.
The issue is affecting EU Acquiring merchants who will experience a one business day delay.

We apologize for the impact this issue has on your business.
We value your partnership and appreciate your understanding while we are remediating the situation.
MIM Paysafe

Reference ID: INC0268413
Posted Jun 26, 2025 - 14:18 UTC
This incident affected: Processing and APIs (Merchant Payments) and Third Parties (Paysafe Acquiring RS2 - Batch Processing).