Worldpay Service Disruption
Incident Report for Paysafe
Resolved
Please be advised that there was a short degradation with Worldpay Vantiv.
Our technical teams were immediately notified and have confirmed that everything is once again stable and working as expected.  

SRO Paysafe
Posted May 03, 2024 - 02:51 UTC
Investigating
We are investigating а potential issue with our Worldpay Vantiv provider and apologize for the impact this might have on your business.

Further updates will follow.

MIM Paysafe
Posted May 03, 2024 - 02:27 UTC
This incident affected: Third Parties (Worldpay Vantiv).