OPTIC portal transaction display inconsistencies

Incident Report for Paysafe

Update

Please be advised that we have successfully implemented a fix for the displaying of incorrect Merchant transaction ID in the Optic Portal issue - INC0271386
The fix has been thoroughly validated and confirmed to be working for newly created transactions.
Historical data for transactions created in the period 15th to 29th of July will be corrected in a timely manner.
We apologize for the impact this might have on your business.
Further updates will follow once all historical data is corrected.

MIM Paysafe

Reference ID: INC0271386
Posted Aug 01, 2025 - 07:24 UTC

Update

Please note that in addition to the incorrect display of Merchant transaction IDs reported, our teams identified that the status of some transactions may be inconsistent, remaining as "Payable" even though they are already completed or expired. Please note that Processing is not affected, only the visualization of those payment handles. A fix is already being designed and will be implemented as soon as possible. Thank you for your understanding.

MIM Paysafe

Reference ID: INC0271386 & INC0273139
Posted Jul 29, 2025 - 17:59 UTC

Identified

The root cause of this incident has been identified and our technical teams are working on implementing a solution.
We will keep you informed on the progress.

MIM Paysafe

Reference ID: INC0271386
Posted Jul 24, 2025 - 14:25 UTC

Investigating

We are investigating an issue with the display of Merchant transaction ID in the Optic Portal.
Some users may observe an incorrect transaction ID related to multiple transactions.
Our teams are working on implementing a solution with the highest priority.
We apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID: INC0271386
Posted Jul 17, 2025 - 11:06 UTC
This incident affects: Merchant Portals (OPTIC Portal).