Merchant Payments Service Disruption

Incident Report for Paysafe

Monitoring

Please note a fix has been implemented and we are closely monitoring the results.
As a result of the incident some merchants whose processing accounts are linked to GLOBAL PAYMENTS in Canada may face a one business day delay on funding of some transactions processed on March 25th
We apologize for the impact this has on your business.
Thank you for your understanding.

MIM Paysafe

Reference ID: INC0301739
Posted Mar 26, 2026 - 17:37 UTC

Investigating

Please be advised that due to a technical issue, some merchants may face a one business day delay on funding of some transactions processed on March 25th.
The issue is being investigated with the highest priority.
We apologize for the impact this has on your business.
Thank you for your understanding.

MIM Paysafe

Reference ID: INC0301739
Posted Mar 26, 2026 - 14:39 UTC
This incident affects: Processing and APIs (Merchant Payments).