The incident has been resolved successfully and the impacted services are fully restored. We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner Worldpay Vantiv was remediating the situation. MIM Paysafe
Reference ID: INC0257291
Posted Apr 09, 2025 - 08:05 UTC
Monitoring
Our provider Worldpay Vantiv implemented a solution and we are monitoring the impacted services.
MIM Paysafe
Reference ID: INC0257291
Posted Apr 09, 2025 - 07:59 UTC
Update
Please note the errors have subsided. Our teams are still investigating, we will keep you informed on further progress.
MIM Paysafe
Reference ID: INC0257291
Posted Apr 09, 2025 - 07:58 UTC
Investigating
We are investigating а potential issue with our Worldpay Vantiv provider and apologize for the impact this might have on your business.
Further updates will follow.
MIM Paysafe
Posted Apr 09, 2025 - 07:48 UTC
This incident affected: Third Parties (Worldpay Vantiv).