Global Payments Service Disruption
Incident Report for Paysafe
Resolved
The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe
Posted Nov 06, 2024 - 05:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2024 - 05:09 UTC
Investigating
We are investigating а potential issue with our Global Payments provider and apologize for the impact this might have on your business.

Further updates will follow.

MIM Paysafe
Posted Nov 06, 2024 - 05:00 UTC
This incident affected: Third Parties (Global Payments).