Global Microsoft Issue
Incident Report for Paysafe
Resolved
Dear All,

As we have observed all systems to be working properly, we will hold the incident as resolved successfully.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe
Posted Jul 20, 2024 - 13:02 UTC
Monitoring
Dear All,

Please be advised that we are aware of a global issue affecting multiple Microsoft Services.
Our teams have performed thorough investigation and confirmed that all Paysafe services are unaffected and fully operational.
Proactive measures to maintain the integrity and performance of our services have been implemented.
We will continue to closely monitor the situation.
If you experience any delays, transaction failures, or anything else unusual please alert Paysafe immediately.

MIM Paysafe
Posted Jul 19, 2024 - 12:57 UTC
This incident affected: Third Parties (Microsoft).