Service Disruption
Incident Report for Paysafe
Resolved
The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe
Posted Jul 18, 2024 - 12:03 UTC
Identified
The root cause of this incident has been identified and our technical teams are working on implementing a solution.
We will keep you informed on the progress.

MIM Paysafe
Posted Jul 18, 2024 - 09:31 UTC
Investigating
We are investigating an issue with Apple Pay on our Merchant TEST environment. We apologize for the inconvenience caused.

Further updates will follow.

MIM Paysafe
Posted Jul 17, 2024 - 17:06 UTC
This incident affected: Non-Production (Merchant Test).