Service Disruption
Incident Report for Paysafe
Resolved
The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe
Posted Nov 14, 2024 - 17:04 UTC
Identified
We are aware of the delay with the October Fiserv merchant billing statements and are actively working to resolve the issue. We apologize for any inconvenience this may have caused and will follow up once the issue is resolved.

As a reminder, your Clover merchants can access their merchant statements directly through their Clover dashboard for faster visibility. Thank you.

MIM Paysafe
Posted Nov 04, 2024 - 21:33 UTC
This incident affected: Third Parties (Fiserv First Data).