Service Disruption
Incident Report for Paysafe
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 16:58 UTC
Identified
The root cause of the incident has been identified and the technical teams are working on implementing a solution.

Further updates to follow.

MIM Paysafe
Posted Apr 25, 2024 - 16:02 UTC
Investigating
We are currently experiencing issues with the services mentioned below. We apologize for the inconvenience this may cause.

Further updates to follow.

MIM Paysafe
Posted Apr 25, 2024 - 15:43 UTC
This incident affected: Processing and APIs (Hosted API (UPP)).