Service Disruption - EU Acquiring Merchant Payments & Reports

Incident Report for Paysafe

Resolved

Please note the issue affecting batch transaction processing on our partner's side has now been fully resolved.
Our partner has confirmed full recovery of all impacted services and processes. 
Clearing, merchant funding, and all related report processing are fully restored and operating normally.
Files for all impacted dates - April 21st, 22nd and 23rd have been successfully received and processed. 
Our operational teams are working with the highest priority to consolidate all outstanding payments and release them as soon as possible.
We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner was remediating the situation.  
MIM Paysafe

Reference ID: INC0304363
Posted Apr 23, 2026 - 08:36 UTC

Monitoring

Please be advised that following our previous communication, our partner has confirmed that processing for the April 21st has now been completed.
However, processing of the current business - April 22nd is still ongoing.
As a result, Paysafe Acquiring (Europe) merchants may continue to experience delays in clearing, merchant funding and payment details & account statement report.
Our partner continues to work with the highest priority to restore normal service levels as soon as possible.
Thank you for your understanding and apologize for the impact this might have on your business!
Further updates will follow.

Reference ID: INC0304363
Posted Apr 22, 2026 - 09:47 UTC

Identified

Please be advised that due to a technical issue on our processor side, Paysafe Acquiring (Europe) merchants and may be affected by a funding delay today. They have also confirmed that clearing of transactions is delayed which will result in delayed postings and may result in delayed funding.

Our processor is working with the highest priority on resolving the issues and restoring normal batch processing.
Thank you for your understanding and apologize for the impact this might have on your business!
Further updates will follow.

Reference ID: INC0304363
Posted Apr 21, 2026 - 15:19 UTC

Investigating

Dear All,

Please be advised that due to a technical issue on our partner side, EU Acquiring merchants and partners payments and reports may be processed with a one day delay.

Our partner is working with the highest priority on resolving the issues and restoring normal batch processing.
Thank you for your understanding and apologize for the impact this might have on your business!
Further updates will follow.

MIM Paysafe

Reference ID: INC0304363
Posted Apr 21, 2026 - 08:56 UTC
This incident affected: Third Parties (Paysafe Acquiring RS2 - Batch Processing, Paysafe Acquiring RS2 - Invoices, Paysafe Acquiring RS2 - Financial Reporting).