The incident has been resolved successfully and the impacted services are fully restored. We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner Banco de Crédito del Perú (BCP) was remediating the situation. MIM Paysafe
Reference ID: INC0312201
Posted Jul 01, 2026 - 02:20 UTC
Update
We are continuing to investigate this issue.
Posted Jul 01, 2026 - 00:51 UTC
Update
We are continuing to investigate this issue.
Posted Jul 01, 2026 - 00:17 UTC
Update
We are continuing to investigate this issue.
Posted Jul 01, 2026 - 00:16 UTC
Investigating
Our partner Banco de Crédito del Perú (BCP) is investigating a potential issue with their services. We apologize for the impact this might have on your business. Further updates will follow.
MIM Paysafe
Reference ID: INC0312201
Posted Jul 01, 2026 - 00:04 UTC
This incident affected: PagoEfectivo (CIP Generation, Banco de Crédito del Perú (BCP), QR Payments) and SafetyPay (Banco de Crédito del Perú (BCP)).