Service Disruption - RS2

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner RS2 was remediating the situation.
MIM Paysafe

Reference ID: INC0300703
Posted Mar 17, 2026 - 19:53 UTC

Monitoring

Please note that we are aware of an increase in transaction failures impacting a specific issuer, primarily under BIN 456933.
Please note that Paysafe and our downstream providers' systems are operating as expected. This has been confirmed by VISA as an issuer-side issue, and the issuer is actively investigating.
MIM Paysafe

Reference ID: INC0300703
Posted Mar 17, 2026 - 19:28 UTC
This incident affected: Third Parties (Paysafe Acquiring RS2 - Real-Time Processing).