Please note we have completed processing all refunds for transactions affected between October 9 and November 26. Handpoint has implemented and thoroughly validated a fix on their side, and no further issues have been detected. We apologize for the inconvenience caused while our partner was remediating the situation. If you have any questions, please contact your account manager or email technicalsupport@paysafe.com.
MIM Paysafe Reference ID: INC0289048
Posted Dec 19, 2025 - 16:37 UTC
Investigating
Please note, settlement cancellations between Oct 9–Nov 26 may not have processed due to a Handpoint issue. Consumers could still see charges. Paysafe is working with Handpoint to return funds. We appreciate your patience as we work alongside our partner for a timely resolution. Questions? Please contact your account manager or email technicalsupport@paysafe.com. MIM Paysafe
Reference ID: INC0289048
Posted Dec 08, 2025 - 16:14 UTC
This incident affected: Third Parties (Handpoint (Interac)).