Paysafe Acquiring RS2 - Real-Time Processing Service Disruption

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe

Reference ID: INC0255097
Posted Mar 11, 2025 - 12:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.

Reference ID: INC0255097
Posted Mar 11, 2025 - 11:59 UTC

Investigating

We are investigating (a) potential issue(s) with the service(s) mentioned below and apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID: INC0255097
Posted Mar 11, 2025 - 11:17 UTC
This incident affected: Third Parties (Paysafe Acquiring RS2 - Real-Time Processing).