Fiserv Service Disruption

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business. Please note that the errors were restricted to VISA transactions. We value your partnership and appreciate your understanding while our partner Fiserv was remediating the situation.
MIM Paysafe

Reference ID:INC0258008
Posted Apr 17, 2025 - 23:14 UTC

Investigating

We are investigating а potential issue with our Fiserv (First Data) provider and apologize for the impact this might have on your business.

Further updates will follow.

Reference ID: INC0258008

MIM Paysafe
Posted Apr 17, 2025 - 22:09 UTC
This incident affected: Third Parties (Fiserv First Data).