Service Disruption - Merchant & Partner Support

Incident Report for Paysafe

Resolved

Please note that the Payment processing email support queues for merchant and technical support have been restored and are now fully operational.
Our support teams can now respond to tickets through the usual channels. Normal service has been resumed.
We apologize for any inconvenience this may have caused to your business.
Thank you for your patience.

Reference ID: INC0307190
Posted May 15, 2026 - 22:34 UTC

Investigating

Please note that Payment processing email support queues for merchant and technical support are temporarily inaccessible to our support teams.
As a result, there might be a delay in our support team's ability to respond to your support tickets.
Until further notice for system and processing critical matters, please contact your account manager or dedicated support phone line to have your problem investigated.
We apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID:
Posted May 15, 2026 - 20:51 UTC
This incident affected: Non-Production (Merchant & Partner Support phone lines).