Merchant Payments Service Disruption

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner Moneris was remediating the situation.
MIM Paysafe

Reference ID: INC0256814
Posted Apr 03, 2025 - 18:35 UTC

Identified

Please be advised that following an issue with our partner Moneris, merchants integrated with Moneris will experience a delay in funding and reporting.
We apologize for the impact this issue may have on your business.
We value your partnership and appreciate your understanding.

MIM Paysafe

Reference ID: INC0256814
Posted Apr 03, 2025 - 15:20 UTC
This incident affected: Processing and APIs (Batch Upload, Merchant Payments) and Third Parties (Moneris).