RS2 Service Disruption
Incident Report for Paysafe
Resolved
This incident has been resolved.
Posted Apr 27, 2024 - 22:22 UTC
Investigating
We are currently experiencing issues with our RS2 provider. We apologize for the inconvenience this may causе.

Further updates to follow.

MIM Paysafe
Posted Apr 27, 2024 - 21:51 UTC
This incident affected: Third Parties (Paysafe Acquiring RS2).