Service Disruption - Merchant Payments

Incident Report for Paysafe

Update

We are continuing to monitor for any further issues.
Posted Feb 06, 2026 - 15:10 UTC

Monitoring

Please be advised that due to a technical issue, some merchants may face a one business day delay on funding of some transactions processed on February 5th evening.

The issue has been identified and corrected and no further delays are expected. We apologize for the impact this has on your business. Thank you for your understanding.

MIM Paysafe

Reference ID: INC0296050
Posted Feb 06, 2026 - 15:10 UTC
This incident affects: Processing and APIs (Merchant Payments).