US Merchant Billing Statements Delay
Incident Report for Paysafe
Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 15:40 UTC
Investigating
This is to notify that there will be delays with the December Fiserv merchant billing statements. We apologize for any inconvenience this may cause and will follow up once the statements have been loaded.

As a reminder, your Clover merchants can access their merchant statements directly through their Clover dashboard for faster visibility. Thank you.
Posted Jan 07, 2025 - 16:44 UTC
This incident affected: Third Parties (Fiserv First Data).