Service Disruption-Multibanco

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner SIBS was remediating the situation.
MIM Paysafe

Reference ID: INC0296444
Posted Feb 10, 2026 - 16:43 UTC

Monitoring

Please be advised that we identified a brief disruption on the Multibanco and MBway payment methods provided by SIBS, between 15:59 and 16:06 UTC. The service has since recovered and we're monitoring to ensure stability

MIM Paysafe

Reference ID:INC0296444
Posted Feb 10, 2026 - 16:16 UTC
This incident affected: Third Parties (Multibanco).