Partner Maintenance - Interac

Scheduled for Aug 5, 08:00 - 10:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 29, 2026 - 15:48 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 29, 2026 - 15:45 UTC

Scheduled

Please be advised that our partner Interac (Peoples Group) will be performing planned maintenance on their e-Transfer service.

Transaction failures are expected during a 10-minute period within the first 30 minutes of the scheduled maintenance window. During this outage, all transactions processed are expected to fail. Based on the information provided, the anticipated impact is expected to occur between 4:00 AM and 4:30 AM, within the overall 4:00 AM to 6:00 AM two-hour maintenance window.

Reference ID: CHG0335694
Posted Jul 27, 2026 - 21:03 UTC
This scheduled maintenance affects: Third Parties (Interac e-Transfer).