Service Disruption
Incident Report for Paysafe
Resolved
Please be informed that the issue with Interac has been resolved and did not impact any of our processing.

SRO Paysafe
Posted Apr 16, 2024 - 12:31 UTC
Monitoring
Please be advised that upon further investigation, no impact has been detected due to this issue. Teams continue to monitor.

SRO Paysafe
Posted Apr 15, 2024 - 17:47 UTC
Investigating
We are currently experiencing issues with the services mentioned below. We apologize for the inconvenience this may cause.

Further updates to follow.

SRO Paysafe
Posted Apr 15, 2024 - 17:21 UTC
This incident affected: Third Parties (Interac (People's Payments)).