Barclays Service Disruption
Incident Report for Paysafe
Resolved
Please be advised this was a short glitch that impacted a very limited number of transactions.

We apologize for the inconvenience and thank you for your understanding.

SRO Paysafe
Posted Apr 28, 2024 - 02:15 UTC
Investigating
We are currently experiencing issues with our Barclays provider. We apologize for the inconvenience this may causе.

Further updates to follow.

SRO Paysafe
Posted Apr 28, 2024 - 02:06 UTC
This incident affected: Third Parties (Barclays Gateway).