Global Payments Service Disruption

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner Global Payments was remediating the situation.
MIM Paysafe

Reference ID:INC0257399
Posted Apr 10, 2025 - 07:40 UTC

Monitoring

Our provider Global Payments implemented a solution and we are monitoring the impacted services.

MIM Paysafe

Reference ID:INC0257399
Posted Apr 10, 2025 - 07:31 UTC

Investigating

We are investigating а potential issue with our Global Payments provider and apologize for the impact this might have on your business.

Further updates will follow.

MIM Paysafe
Posted Apr 10, 2025 - 07:24 UTC
This incident affected: Third Parties (Global Payments).