Service Disruption - SafetyPay via paysafecard
Incident Report for Paysafe
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 00:44 UTC
Investigating
Dear business partner,

We are experiencing issues which affect the SafetyPay service.
We are working on a solution and will provide you with an update as soon as possible.

If you have any questions, please don't hesitate to contact us at techsupport@paysafecard.com
Posted Apr 19, 2024 - 00:39 UTC
This incident affected: Paysafecard (merchant) (eCash SafetyPay).