Service Disruption - Banco Pichincha

Incident Report for Paysafe

Resolved

This incident has been resolved.
Posted Aug 11, 2026 - 23:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 11, 2026 - 22:20 UTC

Investigating

We are investigating a potential issue with the service mentioned below and apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID: INC0317185
Posted Aug 11, 2026 - 16:04 UTC
This incident affected: SafetyPay (Banco del Pichincha).