Service Disruption - Consumer Wallet Withrawals to JP Morgan bank accounts

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe

Reference ID: INC0307233
Posted May 16, 2026 - 16:35 UTC

Investigating

We are investigating an issue with user withdrawals from Skrill Consumer Wallets to JP Morgan bank accounts.
We are investigating alongside the bank with the highest priority.
Further updates will follow.

MIM Paysafe

Reference ID: INC0307233
Posted May 16, 2026 - 11:35 UTC
This incident affected: Skrill (Skrill Consumer Wallet).