Service Disruption - PayPal
Incident Report for Paysafe
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 16:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2024 - 15:21 UTC
Update
We are continuing to investigate this issue.
Posted Nov 06, 2024 - 14:56 UTC
Investigating
Please be advised that we experience degradation with our partner Paypal.

Further updates will follow.

MIM Paysafe
Posted Nov 06, 2024 - 14:55 UTC
This incident affected: Third Parties (PayPal).