Service Disruption - PagoEfectivo via paysafecard
Incident Report for Paysafe
Resolved
The incident has been resolved successfully and the services are fully restored.
We apologize for the inconvenience and thank you for your understanding.

MIM Paysafe
Posted Apr 17, 2024 - 18:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2024 - 16:06 UTC
Investigating
Dear business partner,

We are experiencing issues which affect the PagoEfectivo service.

We are working on a solution and will provide you with an update as soon as possible.
If you have any questions, please don't hesitate to contact us at techsupport@paysafecard.com
Posted Apr 17, 2024 - 15:41 UTC
This incident affected: Paysafecard (merchant) (eCash PagoEfectivo).