Service Disruption - Interac

Incident Report for Paysafe

Resolved

Our provider Interac has performed a scheduled maintenance and downtime was expected. We will continue to monitor the service to ensure system stability.

MIM Paysafe

Reference ID: INC0292721
Posted Jan 10, 2026 - 08:56 UTC

Identified

Our provider Interac has identified the root cause and is working on implementing a solution.
MIM Paysafe

Reference ID: INC0292721
Posted Jan 10, 2026 - 08:13 UTC

Investigating

Our partner Interac is investigating a potential issue with their services. We apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID: INC0292721
Posted Jan 10, 2026 - 07:37 UTC
This incident affected: Third Parties (Interac e-Transfer).