Interchecks Service Disruption

Incident Report for Paysafe

Resolved

Dear All,

Please be advised that the degradation in Interchecks processing, previously reported, has subsided. There’s no indication of an internal system failure on the PaySafe or Interchecks side. The teams have closely monitored the service, and it has now stabilized. We will continue to observe for any recurrence and provide further updates if necessary.

Best Regards,

Reference ID: INC0255490
Posted Mar 16, 2025 - 14:53 UTC

Monitoring

Deal all,

Please be advised that we are experiencing degradation with Interchecks.

The degradation in Interchecks processing has been traced to Visa/Mastercard, indicating that the issuing banks (Stride Bank and The Bancorp Bank) were unavailable to process transactions. There’s no indication of an internal system failure on the PaySafe or Interchecks side. The teams are currently closely monitoring the service.

More update to come.

Reference ID: INC0255490
Posted Mar 16, 2025 - 13:50 UTC
This incident affected: Third Parties (Interchecks).