The incident has been resolved successfully and the impacted services are fully restored. We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while the situation was being remediated.
MIM Paysafe
Reference ID: INC0258504
Posted Apr 25, 2025 - 18:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Reference ID: INC0258504
Posted Apr 25, 2025 - 17:47 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 25, 2025 - 16:31 UTC
Identified
The root cause of this incident has been identified and our technical teams are working on implementing a solution. We will keep you informed on the progress.
MIM Paysafe
Reference ID: INC0258504
Posted Apr 25, 2025 - 15:57 UTC
Investigating
We are investigating issues with our SafetyPay service and apologize for the impact this might have on your business. Our technical teams are working on a solution and will keep you informed on progress.