Migration of Skrill and Neteller Merchant Portals to SSO
Incident Report for Paysafe
Resolved
Dear All,

Please be advised that we have completed the migration of Skrill and Neteller merchant portals to SSO.
As part of the migration users are now required to initiate login using the new unified portal - https://portals.paysafe.com/login
Please find below steps to mitigate issues related to the migration:
- If you are using the same login email for Paysafe portal, Skrill portal and NETELLER portal, please use your Paysafe portal credentials.
- If you use the same email for Skrill and NETELLER then use your known credentials for Skrill to access both.
- In case you are receiving "Invalid Credentials" for your SKRILL/NETELLER credentials, please request a password reset link and try again - Forgot Password - Business Portal (paysafe.com) and Reset your password.
We apologize for any inconvenience this may cause you!
Please do not hesitate to contact merchantservices@skrill.com for Skrill or merchantsupport@paysafe.com for NETELLER in case you have further issues.
Posted Nov 04, 2024 - 09:06 UTC
Update
Dear Valued Merchant,

As you are aware we have rolled out our new Single Sign On functionality over the last few days however we have encountered some login issues during the migration.
We deeply regret any issues and apologize for the inconvenience. If you are currently having log in issues please reset your password by clicking 'Forgot your password?' and following the steps. This will resolve your issue.

In addition, we have identified that due to a technical issue, your transactions may not have appeared in your portal. Please understand that the transactions are still processing despite not displaying in your portal. We have now put in corrective action and this issue is resolved.

If you are still having issues please reach out to merchantservices@skrill.com for Skrill or merchantsupport@paysafe.com for NETELLER with any questions.

Sincerely,
Your Skrill & NETELLER Team
Posted Oct 25, 2024 - 19:40 UTC
Monitoring
Dear All,

Please be advised that we have completed the migration of Skrill and Neteller merchant portals to SSO.
As part of the migration users are now required to initiate login using the new unified portal - https://portals.paysafe.com/login
Please find below steps to mitigate issues related to the migration:
- If you are using the same login email for Paysafe portal, Skrill portal and NETELLER portal, please use your Paysafe portal credentials.
- If you use the same email for Skrill and NETELLER then use your known credentials for Skrill to access both.
- In case you are receiving "Invalid Credentials" for your SKRILL/NETELLER credentials, please request a password reset link and try again - Forgot Password - Business Portal (paysafe.com) and Reset your password.
We apologize for any inconvenience this may cause you!
Please do not hesitate to contact merchantservices@skrill.com for Skrill or merchantsupport@paysafe.com for NETELLER in case you have further issues.
Posted Oct 25, 2024 - 12:16 UTC
This incident affected: Skrill (Skrill Merchant Portal) and Neteller (Neteller Merchant Portal).