Service Disruption
Incident Report for Paysafe
Resolved
The incident has been resolved successfully and the services are fully restored.
We apologize for the inconvenience and thank you for your understanding.

MIM Paysafe
Posted Apr 17, 2024 - 18:05 UTC
Monitoring
A solution has been implemented and the current state of the incident is being monitored.

Further updates to follow.

MIM Paysafe
Posted Apr 17, 2024 - 18:00 UTC
Investigating
We are currently experiencing issues with the services mentioned below. We apologize for the inconvenience this may cause.

Further updates to follow.

MIM Paysafe
Posted Apr 17, 2024 - 17:40 UTC
This incident affected: Merchant Portals (NetBanx Netcentre).