RS2 Service Disruption
Incident Report for Paysafe
Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 09:07 UTC
Investigating
Please be advised that Merchants fee invoices for month of December, 2024 are incorrect, missing the amount in the summary section. Our Vendor is currently working on correcting the data.
Posted Jan 08, 2025 - 11:09 UTC
This incident affected: Third Parties (Paysafe Acquiring RS2 - Invoices).