The incident has been resolved successfully and the impacted services are fully restored. We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner TSYS was remediating the situation. MIM Paysafe
Reference ID: INC0265029
Posted Jun 04, 2025 - 14:35 UTC
Identified
Our provider TSYS has identified the root cause and is working on implementing a solution. MIM Paysafe
Reference ID:INC0265029
Posted Jun 03, 2025 - 05:04 UTC
Investigating
Please be advised that following an issue with our partner, some merchants integrated with TSYS may experience a delay in funding and reporting.
We apologize for the impact this issue may have on your business. We value your partnership and appreciate your understanding.
MIM Paysafe
Reference ID: INC0265029
Posted Jun 02, 2025 - 20:08 UTC
This incident affected: Direct Marketing (TSYS USPP Funding).