Service Disruption - PagoEfectivo via paysafecard

Incident Report for Paysafe

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 06:56 UTC

Investigating

We are investigating issues with our PagoEfectivo Service and apologize for the impact this might have on your business.
Our technical teams are working on a solution and will keep you informed on progress.

If you have any questions, please don't hesitate to contact us at techsupport@paysafecard.com
MIM Paysafe

Reference ID: INC0256593
Posted Apr 01, 2025 - 06:52 UTC
This incident affected: Paysafecard (merchant) (eCash PagoEfectivo).