Service Disruption - PagoEfectivo via paysafecard
Incident Report for Paysafe
Resolved
Dear business partner,

The issues which affected our PagoEfectivo service have been resolved as of 11:06 CEST.

If you have any questions, please don't hesitate to contact us at techsupport@paysafecard.com
Posted Apr 17, 2024 - 09:21 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 17, 2024 - 08:10 UTC
Investigating
Dear business partner,

We are experiencing issues which affect the PagoEfectivo service.

Start time: 06:30 CEST

We are working on a solution and will provide you with an update as soon as possible.
If you have any questions, please don't hesitate to contact us at techsupport@paysafecard.com
Posted Apr 17, 2024 - 07:15 UTC
This incident affected: Paysafecard (merchant) (eCash PagoEfectivo).